Page 2 of 2

Re: error message

Posted: 2019-02-25, 9:45
by księżycowy
Apparently I can view the Polish study group thread, but when I click "submit" to reply it gives me the memory error page. Yay. :?

Re: error message

Posted: 2019-02-25, 9:58
by Naava
I can read every other page in Random complaints except the latest one. I didn't have this problem before. :hmm:

Re: error message

Posted: 2019-02-25, 11:51
by Car
When I click on the new posts symbol of that thread, I get the same error message, too.

Re: error message

Posted: 2019-02-25, 13:14
by proycon
Ouch, so it seems that that the migration caused some issues:

- Out of memory bug on viewing PMs (reproduced) and in certain other situations.. not sure what causes this yet.
- I got a failed login because of too many attempts (external IP might not propagate well enough yet so it may think we all come from the same IP (reverse proxy))
- Mail issues (I was expecting this and preparing to fix it, though I'm surprised it works for vijayjohn still then)
- Parts of the non-forum part of unilang are not online yet (known)
- Also, for sake of completion: dev.unilang.org is still offline (less priority)

I'll dive into it and fix it asap! Sorry for the inconvenience!

Re: error message

Posted: 2019-02-25, 13:39
by proycon
- Out of memory bug on viewing PMs (reproduced) and in certain other situations.. not sure what causes this yet.


I restarted the database server and viewing PMs worked again, only I wonder for how long... Is the error gone in other situations too?

Re: error message

Posted: 2019-02-25, 14:25
by Linguaphile
proycon wrote:
- Out of memory bug on viewing PMs (reproduced) and in certain other situations.. not sure what causes this yet.


I restarted the database server and viewing PMs worked again, only I wonder for how long... Is the error gone in other situations too?

Yes! :D I'm not getting the out of memory error on the threads where I saw it before (or in PMs) now. Thank you; I do hope it stays that way. :D

Issues that I do still see:
I did get the "failed login because of too many attempts" message just now, which you mentioned; I actually hadn't seen that one until just now (that's new, it wasn't happening before).
I'm also still not getting email notifications and still get a blank page when I try to got to the "Edit Notifications Options" page in the User Control Panel. Not a big deal, but perhaps useful to know (although if I understood your post right, it sounds like you already knew stuff like that would happen).

Re: error message

Posted: 2019-02-25, 14:44
by SamoSamNina
I can finally access things again. the other day I was able to post to a thread a bit, but I kept encountering the error message when I tried to open any messages in my inbox, and then I started to encounter it when I attempted to post to a thread. I also once received the login too many times thing, but mostly it was the SQL error. seems to be resolved though; I can post to this thread :)

Re: error message

Posted: 2019-02-25, 14:47
by proycon
- I got a failed login because of too many attempts (external IP might not propagate well enough yet so it may think we all come from the same IP (reverse proxy))


This should now be gone too (so please let me know if you still get it)

Re: error message

Posted: 2019-02-25, 14:49
by proycon
I'm also still not getting email notifications and still get a blank page when I try to got to the "Edit Notifications Options" page in the User Control Panel. Not a big deal, but perhaps useful to know (although if I understood your post right, it sounds like you already knew stuff like that would happen).


Hmm, that particular one is new to me and I can't reproduce it. I'll put it on the list but with a lower priority.

Re: error message

Posted: 2019-02-25, 14:50
by proycon
Correction, it does reproduce, I was looking in the wrong place :)


Code: Select all

2019/02/25 15:51:48 [error] 21066#21066: *380607 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Declaration of phpbb\notification\type\admin_activate_user::create_insert_array($user, $pre_create_data) must be compatible with phpbb\notification\type\base::create_insert_array($type_data, $pre_create_data = Array) in /home/unilang/unilangforum/phpBB3/phpbb/notification/type/admin_activate_user.php on line 0" while reading response header from upstream, client: 10.252.116.1, server: forum.unilang.org, request: "GET /ucp.php?i=ucp_notifications&mode=notification_options HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock:", host: "forum.unilang.org", referrer: "https://forum.unilang.org/ucp.php?i=165"


(upstream bug report: https://tracker.phpbb.com/browse/PHPBB3-15497)

Should be fixed now

Re: error message

Posted: 2019-02-25, 15:02
by Linguaphile
proycon wrote:
- I got a failed login because of too many attempts (external IP might not propagate well enough yet so it may think we all come from the same IP (reverse proxy))


This should now be gone too (so please let me know if you still get it)

I don't get that anymore, thanks.

Re: error message

Posted: 2019-02-25, 16:17
by proycon
Notifications mails should be fixed too (will come from unilang@anaproy.nl now though).

Re: error message

Posted: 2019-02-25, 17:19
by Linguaphile
proycon wrote:Notifications mails should be fixed too (will come from unilang@anaproy.nl now though).

Yes, thank you. I think everything looks good now. :D

Re: error message

Posted: 2019-02-25, 21:38
by vijayjohn
Now it looks like I can't access my PMs by clicking on the PM icon again. :P But again, I can still access them by going through the user control panel.

Re: error message

Posted: 2019-02-25, 21:52
by proycon
Hmm, I can't replicate that, seems to work fine for me.

Re: error message

Posted: 2019-02-25, 22:02
by vijayjohn
Hopefully it'll end up resolving itself in a matter of hours, which is what happened last time anyway. :lol:

Re: error message

Posted: 2019-02-26, 2:43
by dEhiN
proycon wrote:Notifications mails should be fixed too (will come from unilang@anaproy.nl now though).

I still don't seem to be getting notification emails. Also, for some reason when I click on the notification for the Issues & Bugs thread, I get a blank page. The url it takes me to is https://forum.unilang.org/viewtopic.php ... 2#p1130972. But when I go to the Information forum and then click on the new posts icon for the Issues & Bugs thread, it works but the url it takes me to is https://forum.unilang.org/viewtopic.php ... 5#p1131145.

Re: error message

Posted: 2019-02-26, 22:43
by proycon
I can reproduce the blank page error for the first link.

Code: Select all

 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to a member function getName() on null in /home/unilang/unilangforum/phpBB3/includes/functions.php:5117
Stack trace:
#0 /home/unilang/unilangforum/phpBB3/includes/functions.php(4083): page_header(NULL)
#1 [internal function]: msg_handler(1024, 'NO_TOPIC', '/home/unilang/u...', 259, Array)
#2 /home/unilang/unilangforum/phpBB3/viewtopic.php(259): trigger_error('NO_TOPIC')
#3 {main}
  thrown in /home/unilang/unilangforum/phpBB3/includes/functions.php on line 5117" while reading response header from upstream,


Re: error message

Posted: 2019-03-08, 5:05
by vijayjohn
Yay, the PM icon works for me again now! :D

EDIT: ...Okay, not anymore. (But of course I can still access them).

Re: error message

Posted: 2019-03-09, 2:52
by vijayjohn
Now I can't read my PMs anymore. :(

Anytime I try to click on a PM, I get the following error message:

General Error
SQL ERROR [ mysqli ]

Out of memory; check if mysqld or some other process uses all available memory; if not, you may have to use 'ulimit' to allow mysqld to use more memory or you can add more swap space [1041]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.