Issues and Bugs

This forum is for discussing the ongoing and future projects and resources of UniLang. Please post your comments, criticism and ideas here. We are always trying to expand on things members find useful, helpful, or fun! This is also the place to report errors in systems and resources on the UniLang site.

Moderators: Global Moderators, Forum Administrators

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Issues and Bugs

Postby Yserenhart » 2013-09-20, 7:26

Please report any issues you have, or bugs you encounter, while using Unilang here. We will take note of them, and endeavour to fix them. Please use the following format for a report:
Part of the site: [Resources, forum, profile, etc.]
Browser(s) used: [Please list all browsers (with the version) you've used and encountered the problem with.]
Brief description of the issue: [Make sure to include the key details, and any variations in the issue that occur.]

This format makes it easier for us to work on the problem.

Please note that just because something is reported here does not mean it will be fixed immediately, everyone working on this site is doing so voluntarily, and we don't always have a lot of time to devote to it every day, so please be patient after reporting something. Please also consider that some things may not be easy to fix, and might require a time-consuming re-write of that part of the site. Other things might also be noted, but delayed based on either priority or pending a re-working of that part of the site.

Finally, please do not use this thread to request new features, or changes to things that do work fine.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

User avatar
Lauren
Posts: 3581
Joined: 2012-04-09, 7:50
Real Name: Lauren
Gender: female
Location: Seattle, WA
Country: US United States (United States)

Re: Issues and Bugs

Postby Lauren » 2013-09-20, 8:56

- If you go to the main forum page, the language selector on the right only has British English and a broken Brazilian Portuguese.

- On ones profile, the languages are not in alphabetical order. They used to be, and are supposed to be. I was around when they decided to make them in alphabetical order. It still is in the My Languages tab of the UCP.

- The entire wiki is dead.

- Picture gallery is dead too. Might as well remove it since it probably was never updated in recent years.

I'm sure there are many more, since no one has done anything in a long time. :) I'll be sure to post more if I find them.
Native:            [flag=]en-US[/flag]
Advanced:       [flag=]eu[/flag]
Just started:    [flag=]cs[/flag]
Trans woman  Image

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Yserenhart » 2013-09-20, 9:47

Lowena wrote:- On ones profile, the languages are not in alphabetical order. They used to be, and are supposed to be. I was around when they decided to make them in alphabetical order. It still is in the My Languages tab of the UCP.

The languages are sorted by alphabetical order, after they have been sorted by proficiency.

- On that note, in the My Languages tab of the UCP, the star images do not load.

Fixed.

- Also, in the drop-down list of languages, the flags don't show anymore. They did just a week or two ago, so no idea what happened there.

Which drop down list? The one in the UCP does show the flags.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

User avatar
Lauren
Posts: 3581
Joined: 2012-04-09, 7:50
Real Name: Lauren
Gender: female
Location: Seattle, WA
Country: US United States (United States)

Re: Issues and Bugs

Postby Lauren » 2013-09-20, 10:00

Yserenhart wrote:The languages are sorted by alphabetical order, after they have been sorted by proficiency.

Image
There is no alphabetical order in this list.

- On that note, in the My Languages tab of the UCP, the star images do not load.
- Also, in the drop-down list of languages, the flags don't show anymore. They did just a week or two ago, so no idea what happened there.

Sorry, these were problems with my Chrome installaion. Clearing the cache fixed the stars, but not the flags... Oh well, no big deal. Both work fine on my Firefox installation.
Native:            [flag=]en-US[/flag]
Advanced:       [flag=]eu[/flag]
Just started:    [flag=]cs[/flag]
Trans woman  Image

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Yserenhart » 2013-09-20, 10:18

Lowena wrote:There is no alphabetical order in this list.

Okay, that seems to be a problem with only a couple of browsers, in both Firefox and IE the lists display correctly. I'll look into sorting it out with other browsers as well.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

User avatar
Reinder
Language Forum Moderator
Posts: 3755
Joined: 2011-03-22, 17:21
Gender: male
Country: MX Mexico (México)

Re: Issues and Bugs

Postby Reinder » 2013-09-20, 10:21

Yserenhart wrote:Okay, that seems to be a problem with only a couple of browsers, in both Firefox and IE the lists display correctly. I'll look into sorting it out with other browsers as well.
In Opera it doesn't appear alphabetically either.
Image Image Image | Image Image | Image

User avatar
Abavagada
Posts: 2521
Joined: 2002-06-21, 2:26
Real Name: Erik Zidowecki
Gender: male
Location: Ocean Park
Country: US United States (United States)
Contact:

Re: Issues and Bugs

Postby Abavagada » 2013-09-21, 21:38

The picture gallery used external software and it got moved a few times. It was last moved to my server, but by then, people had stopped using it, instead posting images in a thread on the forum. Best to just remove the link to that.

The Wiki fell into general disuse a few years ago, which is one reason Hashi created Wikilang, I believe. When the stuff with the site was discussed a few years ago, there was an effort to port the wiki materials to a new Wikilang, so I doubt the Wiki will be rebuilt. I don't know how far Hashi got with the porting.
"Internet killed the video star. Telepathy killed the internet star." - Men Without Hats
Parleremo - Where Languages Live! http://www.parleremo.org

User avatar
Ashucky
Global Moderator
Posts: 1695
Joined: 2010-11-09, 18:35
Real Name: Andrej
Gender: male
Location: Ljubljana
Country: SI Slovenia (Slovenija)
Contact:

Re: Issues and Bugs

Postby Ashucky » 2013-09-22, 18:12

Abavagada wrote:The Wiki fell into general disuse a few years ago, which is one reason Hashi created Wikilang, I believe. When the stuff with the site was discussed a few years ago, there was an effort to port the wiki materials to a new Wikilang, so I doubt the Wiki will be rebuilt. I don't know how far Hashi got with the porting.
WikiLang's been dead for a while now, too, at least a year, I think.
Slovenščina (sl)English (en)Italiano (it)漢語 (zh)Español (es)Suomi (fi)Svenska (sv)日本語 (ja)فارسی (fa)Nešili (hit)
The greatest enemy of knowledge is not ignorance, it is the illusion of knowledge.
Največji sovražnik znanja ni nevednost, marveč iluzija znanja.

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Yserenhart » 2013-09-22, 20:00

The wiki at this stage has an undecided future, we may try to rebuild it, but not for a while yet if we do, so I'm afraid everyone will have to do without it for now.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

User avatar
MillMaths
Posts: 11897
Joined: 2011-06-15, 9:15
Real Name: George Law
Gender: male
Location: London
Country: GB United Kingdom (United Kingdom)
Contact:

Re: Issues and bugs

Postby MillMaths » 2013-10-08, 21:29

Part of the site: Blogs

Browser used: Mozilla Firefox version 16.0.2

Brief description of the issue: Avatars not aligning (see screenshot)

Image

User avatar
OldBoring
Language Forum Moderator
Posts: 5400
Joined: 2012-12-08, 7:19
Real Name: Francesco
Gender: male
Location: Loma
Country: IT Italy (Italia)
Contact:

Re: Issues and Bugs

Postby OldBoring » 2013-10-12, 5:55

Currently flags are displayed only when opened with the tag [flag=]... but not with the simple [flag]
I would like that they work with the second one, because:

1. this way old flags will continue to display

2. in BBCode standard if you don't have any attribute to add, you don't put the = sign.

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Yserenhart » 2013-10-12, 6:15

The change to the new code has been done to meet past requests from users, as well as to increase the functionality. The reason the "=" is required is due to a bug within the phpBB3 software that the developers have already stated they won't fix; however, you don't need to put anything between the "=" and the "]" for the code to still work. Seeing as the "=" is automatically added by clicking the code on the posting page, it is no extra work for anyone should they not wish to add the optional hover text.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

kevin
Language Forum Moderator
Posts: 1500
Joined: 2012-03-29, 11:07
Gender: male
Country: DE Germany (Deutschland)
Contact:

Re: Issues and Bugs

Postby kevin » 2013-10-12, 6:57

Does this mean that all old messages using flags will remain broken? :?

User avatar
Aurinĭa
Forum Administrator
Posts: 3299
Joined: 2008-05-14, 21:18
Gender: female
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Aurinĭa » 2013-10-12, 7:17

You can edit your own posts to fix the flags, or if it's a post made by someone else, f.ex. in the Translations subforum, you can quote it and edit the code.

User avatar
TheStrayCat
Language Forum Moderator
Posts: 2401
Joined: 2010-12-23, 11:49
Real Name: Max
Gender: male
Location: Evanston, IL
Country: US United States (United States)
Contact:

Re: Issues and Bugs

Postby TheStrayCat » 2013-10-12, 10:10

So, the problem is that the engine cannot process two tags, [flag] and more user-friendly [flag=], at the same time due to the coincidence in names? Why couldn't you then introduce a new alias, like [fl=], for the more functional template while retaining [flag] as a deprecated option? I mean, it would be possible to use it, mainly to prevent signatures and older posts from distortion, but it wouldn't appear in the panel over the posting window.
Native: [flag=]uk[/flag]
C1: [flag=]en-US[/flag]
B2: [flag=]es[/flag]
A1: [flag=]fr[/flag][flag=]hr[/flag]

User avatar
voron
Language Forum Moderator
Posts: 3670
Joined: 2007-07-15, 3:29
Real Name: Igor
Gender: male
Country: BY Belarus (Беларусь)

Re: Issues and Bugs

Postby voron » 2013-10-12, 12:17

Guys the flags are all over the forum, and the way the are rendered now makes the posts essentially unreadable... We cannot leave them like that. :(

User avatar
Yserenhart
Server Administrator
Posts: 767
Joined: 2009-11-09, 2:56
Country: BE Belgium (België / Belgique)

Re: Issues and Bugs

Postby Yserenhart » 2013-10-12, 21:24

I'm trying to implement a workaround to make the old flags work; however, it is not a simple fix. If I fail to do so then I'll create a thread where anyone can report any thread/signature they want fixing, and I'll go through and try to fix all the old codes in threads and signatures. Until then please be patient, or if you have something you really want fixed send Aurinĭa or me a PM.

Note that almost all the threads on the first page of the translations forum had the flags updated in the last post, and new threads will start with working flags. Give it a week or two and most threads should be pretty much fine.
Native: Derbyshire English (en-GB)/New Zealand English (en-NZ) Learning: Vlaams (nl-BE)

User avatar
Johanna
Forum Administrator
Posts: 6268
Joined: 2006-09-17, 18:05
Real Name: Johanna
Gender: female
Location: Lidköping, Westrogothia
Country: SE Sweden (Sverige)

Re: Issues and Bugs

Postby Johanna » 2013-10-12, 22:58

Apparently we can't fix it, even if we were to revert to the old codes, they will only work in new posts.

And believe me, no one wanted this, all we wanted was to fix the issue with the links and the fact that the hover text only gave the code and not the name of the language. Then something went wrong, and now things are like they are so let's move forward, shall we?

We had a similar crisis a few years back, which broke old links, but we managed to move past that :)
Swedish (sv) native; English (en) good; Norwegian (no) read fluently, understand well, speak badly; Danish (dk) read fluently, understand badly, can't speak; Faroese (fo) read some, understand a bit, speak a few sentences; German (de) French (fr) Spanish (es) forgetting; heritage language, want to understand and speak but can't.

User avatar
Ashucky
Global Moderator
Posts: 1695
Joined: 2010-11-09, 18:35
Real Name: Andrej
Gender: male
Location: Ljubljana
Country: SI Slovenia (Slovenija)
Contact:

Re: Issues and Bugs

Postby Ashucky » 2013-10-13, 0:27

If you want a post or a signature fixed (regarding the new flag code), feel free to send me a PM as well. Yserenhart's got a lot on his plate as it is :)
Slovenščina (sl)English (en)Italiano (it)漢語 (zh)Español (es)Suomi (fi)Svenska (sv)日本語 (ja)فارسی (fa)Nešili (hit)
The greatest enemy of knowledge is not ignorance, it is the illusion of knowledge.
Največji sovražnik znanja ni nevednost, marveč iluzija znanja.

User avatar
Lauren
Posts: 3581
Joined: 2012-04-09, 7:50
Real Name: Lauren
Gender: female
Location: Seattle, WA
Country: US United States (United States)

Re: Issues and Bugs

Postby Lauren » 2013-10-13, 1:24

When I was a developer, I knew Proycon had a mirror of the site for testing. I assume not anymore? Or else you could have tested this.
Native:            [flag=]en-US[/flag]
Advanced:       [flag=]eu[/flag]
Just started:    [flag=]cs[/flag]
Trans woman  Image


Return to “Unilang - Information, Input, and Questions”

Who is online

Users browsing this forum: No registered users and 1 guest